EXCEL: COME SOMMARE E CONTARE LE CELLE CON LO STESSO COLORE DI SFONDO

Excel come sommare e contare le celle colorate

Il popolare programma non ha una funzione diretta per sommare e contare i valori con lo stesso colore di sfondo, ma esiste un modo semplice per aggirare l’ostacolo senza scrivere righe di codice.

Excel è uno strumento versatile, molto utile per gestire la contabilità famigliare o di un’azienda, il magazzino, indirizzi/contatti ed altre informazioni organizzate in fogli e tabelle.

ll colore di sfondo è la maniera più veloce per evidenziare dati da usare per dei subtotali, come somme o conteggi.

Una vecchia funzione macro GET.CELL (in italiano INFO.CELLA) consente di ottenere una lista di caratteristiche senza VBA, acronimo di Visual Basic for Applications un’implementazione di Microsoft per Office. L’unica difficoltà è che non si può utilizzare direttamente nel foglio-lavoro, ma si dovrà prima ricavare un elemento da mettere in relazione. Vediamo come fare.

Iniziamo creando una traccia base di un bilancio famigliare mensile inserendo spese per: autostrada, benzina, pizzeria, supermercato, bollette, mercato, rata mutuo ed una voce che lasceremo con lo sfondo bianco.

Excel traccia per bilancio famigliare mensile

 

Per tenere le spese sotto controllo, aggiungiamo una colonna con il Totale Progressivo che dovrà essere uguale al Totale del Mese. Usiamo formule diverse per incrociare i metodi di calcolo verificando la correttezza.

Per il Totale Progressivo digitiamo nella barra funzione:

=SOMMA(C3+D2)

con il Copia ed Incolla riportiamo la formula in tutte le celle.

Il Totale del Mese è pari alla somma dell’intero range della Colonna Uscite:

=SOMMA(C3:C10)

Suddividiamo le voci immesse in Causale usando i colori che andremo a sommare e contare mettendo in risalto i risultati in quattro colonne con le rispettive tinte: Casa (arancione), Cibo (blu chiaro), Trasporti (giallo), Tempo libero (verde chiaro).

Suddivisione tipo di spese in base ai colori rispettive colonne

Prima di procedere controlliamo che il Menu Macro sia attivo. Niente paura, non useremo VBA, ma sfrutteremo la funzionalità. Se il Menu non fosse attivo, andiamo nelle opzioni di Sicurezza e Privacy e scegliamo di abilitare tutte le Macro, ricordandoci di disabilitare il flag una volta terminato il lavoro per evitare che file scaricati dal web siano potenzialmente pericolosi per il computer.

Inseriamo una colonna. Spostiamoci in Formule e clicchiamo su Definisci Nome.

Excel formule Definisci nome per INFO.CELLA

Nella finestra che compare digitiamo Idcolore nel nome per poi scrivere il comando chiave per il nostro progetto:

=INFO.CELLA(38; Foglio1! B3) 

Ricordiamo che INFO.CELLA equivale a GET.CELL.

L’argomento 38 restituisce il colore di sfondo della cella classificando i colori da 1 a 56.

Andiamo nella prima cella della colonna Idcolore ed inseriamo nella barra funzione =Idcolore. 

Excel Idcolore in barra funzione per ricavare informazione numerica del colore di sfondo

Il valore restituito compare nella colonna IDcolore.

Ripetiamo per tutte le celle ed avremo i valori numerici corrispondenti ai colori della Colonna Causale, ossia:

46 per Casa in arancione in Causale come Bollette e Rata Mutuo.

37 per Cibo in blu chiaro, in Causale come Supermercato e Mercato.

6 per Trasporti in giallo con le spese di Autostrada e Benzina.

36 per il Tempo Libero in verde chiaro con le spesa della Pizzeria.

A questo punto possiamo sommare le singole voci con colori diversi separando i risultati nelle rispettive colonne.

Per casa

=SOMMA.SE(E3:E10;46;C3:C10)

L’intervallo da considerare è E3:E10 ossia il valore numerico ricavato con INFO.CELLA, il criterio per Casa è 46, il range da sommare è dato dagli importi nella Colonna Uscite C3:C10

Ripetiamo il comando per ogni colonna cambiando il criterio, 37 per Cibo, 6 per Trasporti, 36 per Tempo Libero.

=SOMMA.SE(E3:E10;37;C3:C10)

=SOMMA.SE(E3:E10;6;C3:C10)

=SOMMA.SE(E3:E10;36;C3:C10)

Si nota come il totale delle voci incolonnate per colore sia diverso dal totale del mese. Questo perché avevamo una spesa non colorata di 10 euro. Inseriamo una colonna anche per questa tipologia ed INFO.CELLA restituisce il valore 0 (zero). Rifacendo i calcoli, i conti tornano.

Verifica somme colonne con Totale Mese

Se vogliamo contare le celle colorate basterà cambiare formula ed usare CONTA.SE

=CONTA.SE(E3:E10;46)

Ricordatevi di cambiare il valore dell’argomento, 37 per Cibo, 6 per Trasporti, 36 per Tempo Libero.

Facile e pratico. All’inizio ci vuole un po’ di pazienza, ma questo metodo vi semplificherà la gestione di molti prospetti.

Se avete dei dubbi, guardate il video tutorial sul nostro canale YouTube o nella nostra pagina FB.

 

RIPRODUZIONE RISERVATA – ©2022 SHOWTECHIES – Quando la Tecnologia è spettacolo™

ShowTechies non è responsabile di eventuali danni causati dall’errata applicazione delle formule.

Immagini e Video:  Simona Braga – Vietata la riproduzione dell’articolo e del video senza autorizzazione scritta. 

15 Commenti

  1. Grazie!!!!!!!!E fantastico ho cercato spesso dei tutorial che mi spiegassero come fare ma non ero mai riuscito a capire bene. Complimenti.

  2. Ma è una figata! Non vi conoscevo, ora sono un vostro fan. Ma sapete quanti tutorial inutili mi sono passato e questo mi risolve tutto.

  3. Perfetto per tenere la contabilità. Inviterò i miei figli a tenere le loro spese. Spero imparino quanto spendono in discoteca, aperitivi e telefonini.

  4. Io vorrei distinguere le voci per la partita doppia e poi automaticamente riportarle a bilancio usando i colori. Che dite? Può funzionare?

    • Bella idea. A scuola dovrebbero insegnare anche queste cose. Mia figlia mi costa un patrimonio di cellulari,fili che rompe uno al mese e roba da influencer.

    • Dopo aver inserito la formula in definisci nome, deve inserirla con l’uguale davanti e poi copiarla ed incollarla per tutte le celle della colonna come una funzione. Ci dica se siamo stati d’aiuto. Buon lavoro.

  5. Che figata funziona. Ho passato una settimana a fare ordine nel magazzino ed ora ho le quantità per colore così mi saltano all’occhio quando scarseggiano. Ho pure risparmiato sul consulente.

Lascia un commento

L'indirizzo email non sarà pubblicato.


*